الأحد، 19 أبريل 2015

الوصول والتحكم بالمايكروتك عن بعد ومن أي مكان

بواسطة : الشحات الدكرورى بتاريخ : 7:17 م


الوصول والتحكم بالمايكروتك عن بعد ومن أي مكان


الوصول والتحكم بالمايكروتك عن بعد ومن أي مكان

طلب الكثير من الاخوة شرح هذه الخاصية ورغم وجود الكثير من الطرق التي تعتمد على التسجيل في موقع اخر وانشاء دومين وكتابة اكواد معقدة والكثير الكثير من الطرق الطويلة ولكن اليوم وجدت طريقة مجربة ومختصرة أتمنى ان تنال رضاكم وتنطبق على كل أنواع الراوتر بورد الخاصة بالمايكروتك وكما يلي:

نفتح الون بوكس بشكل طبيعي ثم ننقر على تبويب (system) ونختار منه السكربت (script) وكما في الصورة التالية:


والان ننقر على زر انشاء سكربت جديد من علامة الزائد (+) وكما في الصورة التالية:


والان اتبع التعليمات في الصورة التالية:





واما السكربت الذي يتم نسخه ولصقه فهو كما في ادناه:


# Define User Variables

:global ddnsuser “southbird”

:global ddnspass “mothana”

:global ddnshost “00.00.00.00”

# Define Global Variables

:global ddnsip

:global ddnslastip

:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip “0” }

:global ddnsinterface

:global ddnssystem (“mt-” . [/system package get system version] )

# Define Local Variables

:local int

# Loop thru interfaces and look for ones containing

# default gateways without routing-marks

:foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={

:if ([:typeof [/ip route get $int routing-mark ]] != str ) do={

:global ddnsinterface [/ip route get $int interface] }

}

# Grab the current IP address on that interface.

:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

# Did we get an IP address to compare?

:if ([ :typeof $ddnsip ] = nil ) do={

:log info (“DDNS: No ip address present on ” . $ddnsinterface . “, please check.”)

} else={

:if ($ddnsip != $ddnslastip) do={

:log info “DDNS: Sending UPDATE!”

:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ] :global ddnslastip $ddnsip

} else={

:log info “DDNS: No update required.”

}

}

# End of script


طبعاً لا يجب ان تنسى تغيير اسم المستخدم وكلمة المرور وعنوان حساب ال DNS الخاص بك

ليست هناك تعليقات:

إرسال تعليق

مدونة ميكروتيك المنصورة هي عبارة عن مدونة معلوماتية تضم مجموعة من الدروس و الشروحات التي تفيد الشاب العربي ، بالإضافة إلى مقالات حصرية , مدونة ميكروتيك المنصورة تم تأسيسها سنة 2014 حيث تستقطب العديد من الزوار من كافة الدول العربية عبر الشروحات الحصرية التي تتوفرها ، مدير المدونة بدر الدكرورى.

اشاشترك معنا وتفاعل معنا لتصلك أخر المستجدات والمواضيع الحصرية




جميع الحقوق محفوضة 2015 تصميم و تكويد بدر الدكرورى