الاثنين، 13 أبريل 2015

جعل التصفح بسرعه الخط مع تحديد الدونلود والالعاب الفلاش

بواسطة : الشحات الدكرورى بتاريخ : 11:00 ص

جعل التصفح بسرعه الخط مع تحديد الدونلود والالعاب الفلاش


قبل ما تطبق معانا الفكرة لازم يكون النت عندك يستحمل علي الأقل يكون 4 ميجا 


الفكرة ؟
هنعطى لليوزر سرعة قليلة إفتراضا 256k ودي هتكون سرعة اي تحميل 
وهنستثني منهم
التصفح و الفيديوهات 
والألعاب الأون لاين زي ( المزرعة السعيدة )
هنفتح للتصفح سرعة النت كاملة
وهنعطى للفديوهات والألعاب سرعة ( 1 ميجا او اكتر زي ماتحب )


الشرح تم علي النسخة (5.25) 
لايعمل علي النسخ 6 لأن الشركة غيرت طريقة التوزيع بالنسخة وعموما النسخة 6 زبالة حتي الآن ياريت محدش يتعامل بيها في اي حاجة لحد اما تنتهي لأن هتقابلك مشاكل كتير معاها
المهم 
الصور اللي جاية دي هتوضح الفكرة أكتر
1- اليوزر اللي انا فاتح بيه حاليا علي جهازي في المحل وسرعته ( 256k ) للتجربة
ومن الأفضل أنك تعطي للمشتركين سرعة قليلة ولتكن 400k لأن الأغلبية العظمي من المشتركين بتستخدم التصفح واليوتيوب والألعاب أون لاين في أغلب الأحيان 
وده هيوفر كتير جدا في الباندويث بتاع شبكتك


2- تجربة التحميل باليوزر ده
اي امتداد هنحمله غير اللي قولنا عليهم هيحمل بسرعة البروفايل عادي جدا


نيجي بيقي نشوف التصفح والفيديو والألعاب إيه ظروفهم
3- تجربة التصفح
وهنا التصفح ساحب 3 ميجا وسرعة اليوزر كام ؟ ( 256 كيلو فقط
ثواني ويكون الموقع فاتح 

4- تجربة الفيديو ( يوتيوب كمثال )
سرعة اليوزر 256 والفيديو عامل إزاي 
ساحب للفديو 1 ميجا زي ما حددنا للفيديو مع أن اليوزر 256


5-تجربة الألعاب ( المزرعة السعيدة كمثال)
في ثواني فتح اللعبة


6- إزاي ترفع السرعة للفيديوهات والألعاب أكتر من 1 ميجا


علشان الفيديو ميقطعش مايقلش عن ( 1 ميجا )
7- تعالو نشوف عدد الناس اللي فاتحة معايا حاليا علي خط واحد من الخطوط وسرعته 4 ميجا




8- نيجي بقا للكود المستخدم في العملية دي واللي هيلخص الحكاية دي كلها
قبل ما تضيف الكود امسح اي أكواد قديمة عندك تتعارض مع الكود ده
يوضع في التيرمنال 

ملحوظة : يرجي الضغط علي زر إنتر بعد لصق الكود في التيرمنال حتي يتم 
التأكيد من إدخال الكود بطريقة صحيحة
9- واخير كان في حاجة عايز أوضحها وهيا ( طريقة التخزين المؤقت للصفحات في الـدي إن أس )
بتعمل فرق كبير في التصفح
IP -> DNS من قائمة
أكتب اي DNS سريع 
وأفضل شركتين بيقدموا خدمة دي ان اس مجانية علي مستوي العالم ( جوجل "مفتوح" - نورتون " محمي " )
طريقة التشغيل : اعمل زي الصورة كدة بالظبط وبعد كدة اضغط اوك

ودي المواقع اللي بتتخزن -> من قائمة ( Cache )

ملحوظة : الكاش بيتفرغ تلقائي عند عمل ريستارت للسيرفر

ودا اسكربت التصفح فقط



/ip firewall layer7-protocol
add name=jpg regexp=.jpg
add name=gif regexp=.gif
add name=png regexp=.png

/ip firewall mangle
add action=mark-connection chain=prerouting comment="\C7\E1\CA\D5\DD\CD" disabled=no layer7-protocol=jpg new-connection-mark=Browsing passthrough=yes
add action=mark-connection chain=prerouting disabled=no layer7-protocol=gif new-connection-mark=Browsing passthrough=yes
add action=mark-connection chain=prerouting disabled=no layer7-protocol=png new-connection-mark=Browsing passthrough=yes
add action=mark-packet chain=postrouting connection-mark=Browsing disabled=no new-packet-mark=Browsing passthrough=no

/queue type
add kind=pcq name="Full Speed" pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 \
    pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Browsing packet-mark=Browsing parent=global-out priority=1 queue="Full Speed"

هناك تعليقان (2):

  1. ابعت الرابط للصفحه اللى جه منها الشرح عشان اكتب منقول واحط الرابط جمبها ... بما انك متابع اووى كدا الشرحات كلها المجانى

    ردحذف

مدونة ميكروتيك المنصورة هي عبارة عن مدونة معلوماتية تضم مجموعة من الدروس و الشروحات التي تفيد الشاب العربي ، بالإضافة إلى مقالات حصرية , مدونة ميكروتيك المنصورة تم تأسيسها سنة 2014 حيث تستقطب العديد من الزوار من كافة الدول العربية عبر الشروحات الحصرية التي تتوفرها ، مدير المدونة بدر الدكرورى.

اشاشترك معنا وتفاعل معنا لتصلك أخر المستجدات والمواضيع الحصرية




جميع الحقوق محفوضة 2015 تصميم و تكويد بدر الدكرورى